Outbound webhooks and integrations experienced delays with potential for out-of-order delivery for short period of time

Resolved
Duration: 38mAug 26, 2026

Affected services

Outbound Event Delivery

Partial outage

Timeline

Resolved
19:10Aug 26, 202612h ago

We have resolved the incident.

Outbound Event Delivery
Investigating
18:32Aug 26, 202613h ago

We identified a performance issue affecting outbound webhooks and integrations beginning at 16:32 UTC. During this incident window, event delivery experienced significant delays and there is potential that some events may have been delivered out of order. The issue was contained and resolved by 17:10 UTC. Our team has conducted a thorough review and implemented monitoring to prevent recurrence. Thank you for your patience.