iOS app is currently unavailable on the Apple App Store due to an Apple-side membership renewal processing error; restoration is expected within 24 hours.

  • Now
  • Mar 10, 2026, 12:08:10 PM GMT+1
    Resolved

    Apple has restored the iOS app listing on the App Store and the Apple-side membership renewal processing issue is resolved. We are considering the incident resolved and will continue to keep an eye on availability, but no further impact is expected.

  • Mar 10, 2026, 11:47:29 AM GMT+1
    Monitoring

    Our iOS app is currently unavailable on the Apple App Store. Apple Developer Support has confirmed this was caused by an Apple-side processing error related to our membership renewal.

    Impact: Users cannot download or reinstall the iOS app from the App Store during this period.

    What we’re doing: We are working with Apple Developer Support and tracking their restoration process.

    Next update: The app is expected to be available again within 24 hours, per Apple Developer Support.

    iOS