Recurring on-call schedules are not editable and schedule restrictions are ignored

  • Now
  • May 22, 2023, 11:44:07 AM GMT+2
    Resolved
    We are closing this issue. All recurring schedules are editable and all schedules with restrictions are working as expected. We are very sorry for the inconvenience.
  • May 22, 2023, 11:27:10 AM GMT+2
    Monitoring
    We have fixed the issue and are closely monitoring recurring on-call schedules. Any edits to schedules that were made between 2023-05-22 04:57 UTC and 2023-05-22 09:21 potentially resulted on-call restrictions being ignored. We advise all users that have made changes to recurring on-call schedules in the last 6 hours to verify their schedules.
  • May 22, 2023, 11:11:10 AM GMT+2
    Identified
    The scope of this issue is broader than what our initial analysis revealed. Schedule restrictions are ignored. Therefore, schedules can show users being on-call outside configured on-call hours. We are currently rolling out a fix and expect the fix to be available to all users within the next 20 - 30 minutes.
  • May 22, 2023, 10:32:16 AM GMT+2
    Identified
    We have identified the root cause for this incident and are fixing it.
Affected services
Web Application
Degraded